Issue with our upstream provider

Incident Report for SCCRESA

Resolved

We have received no update from Telnet since yesterday.
We have successfully made calls incoming and outgoing from the affected customer sites. We will be closing out this status.

Questions or concerns please email helpdesk@sccresa.org or call 810-455-1006
Posted Feb 25, 2026 - 07:03 EST

Update

Telnet has Issued the following update:

This issue appears to be an ISP issue, but we are still investigating and working with our escalation team and the ISP.


I’ll keep you posted, and let you know as soon as I have an update for you – thank you for your patience!
Posted Feb 24, 2026 - 15:51 EST

Monitoring

Testing at multiple sites, they can now send and receive calls again. Though we have not had any updates from Telnet on cause or resolution
Posted Feb 24, 2026 - 15:44 EST

Update

Update to status now Inbound and Outbound Calling to PRI customers are down. We have updated the ticket with Telnet
Posted Feb 24, 2026 - 14:38 EST

Investigating

Our upstream provider, Telnet, is currently experiencing an issue which is affecting Telnet PRI Phone Customer.


We will resolve this incident once we have received confirmation the issue has been resolved from our upstream provider.
Posted Feb 24, 2026 - 14:20 EST
This incident affected: Phone Service (TelNet WW - PRI).