The issue has been resolved. Thank you for your patience during the process.
If you experience any further issues, please contact the Helpdesk by visiting helpdesk.sccresa.org, emailing helpdesk@sccresa.org, or by calling (810)455-1006.
Posted Jul 02, 2026 - 14:16 EDT
Monitoring
A solution has been implemented and the SCCRESA IT Helpdesk is monitoring.
We appreciate your patience during the resolution process. For questions or concerns, please contact the SCCRESA IT Helpdesk.
Posted Jul 02, 2026 - 09:02 EDT
Identified
We have experienced a power outage at one of our hub sites. We are working to have power restored. More information to follow.
We appreciate your patience as we work toward resolution. For questions or concerns, please contact the SCCRESA IT Helpdesk.
Posted Jul 02, 2026 - 07:21 EDT
This incident affected: RESA Internet Service (Port Huron Northern Hub Site - 1 GB Internet Service, Port Huron Northern Hub Site - 10 GB Internet Service).